思科模拟器笔记

王忘杰
2021-03-17 / 0 评论 / 178 阅读 / 正在检测是否收录...
温馨提示:
本文最后更新于2021年03月17日,已超过473天没有更新,若内容或图片失效,请留言反馈。

本文记录的是使用思科模拟器搭建:
思科常用命令
ACL访问控制列表vlan隔离+PAT段口多路复用
Rip距离矢量内部网关协议
单臂路由+NAT复用PAT
三层交换SVI+路由器PAT

思科常用命令

#show version 显示版本号
#running-configuration 显示当前配置
#show interfaces ethernet 0/1 显示接口信息
#show ip 显示交换机IP地址
config#hostname sw1 设置主机名
config#ip address 1.1.1.1 255.255.255.0 配置IP地址
config#ip default-gateway 1.1.1.1 配置缺省网关

config#interface e0/1
config#duplex full 配置全双工模式

#setup 初始化配置

#show startup 显示启动配置

config#line console 0
config-line#login
config-line#password cisco 终端密码

config#line vty 0 4 启动5个虚拟终端
config-line#login
config-line#password sanjose

config#enable password cisco 开启密码
config#enable secret sanfran 特权模式密码

config#interface type number 端口标识
config#interface type slot/port 针对模块交换机

配置串行端口
#configure term
config#interface serial 0
config-if#clock rate 64000 设置时钟速率
config-if#bandwidth 64 设置带宽

config-if#shutdown 关闭接口
config-if#no shutdown 开启接口

保存配置
#copy runnig-config startup-config
#write

#reload 重启

#telnet 1.1.1.1 使用telnet连接到远程设备
#<ctrl-shift-6>x 挂起
#resume 1 恢复
#sh session 查看telnet连接
#sh user 查看登陆的用户
#disconnnect 关闭远程回话
#clear line 11关闭被远程打开的回话

#ip name-server 1.1.1.1 绑定hosts

#ping 1.1.1.1
#trace 1.1.1.1

CDP 思科发现协议
PVST+ 思科生成树协议
VTP 思科Vlan同步协议

S1 config#vtp mode server 服务器
S1 config#vtp domain sw 域名
S1 config#vtp password cisco 密码
S2 config#vtp mode client 客户端
S3 config#vtp mode transparent 透明模式

S1 config#interface f0/1
S1 config-if#switchport mode trunk
S1 config-if#switchport trunk native vlan 99
S1 config-if#no shutdown

config#ip route 1.1.1.1 0.0.0.255 静态路由
config#ip route 0.0.0.0 0.0.0.0 1.1.1.1 默认路由

解决路由环路
定义最大值
水平分割
路由毒化
毒性逆转
抑制计时器
触发更新

RIP协议
config#router rip
config-route#network 1.1.1.0
config-route#network 1.1.2.0 直连路由

#show ip protocols 核实rip配置
#sh ip route
#debug ip rip

IGRP
#route igrp 100
#network 1.1.1.0
#network 1.1.2.0 直连路由

EIGRP
#router eigrp 100
#network 1.1.1.0
#network 1.1.2.0 直连路由

OSFP
config#router ospf 1
config-router#net 1.1.1.0 0.0.0.255 area 0
config-router#net 1.1.2.0 0.0.0.255 area 0 宣告路由

config#router ospf 2
config-router#net 0.0.0.0 255.255.255.255 area 0 宣告所有路由

ACL 标准访问列表 范围从1-99
access-list 1 premit 172.16.0.0 0.0.255.255 允许一个网段
接口方向 f0/0
interface ethernet 0
ip access-group 1 out 允许规则
interface ethernet 1
ip access-group 1 out 允许规则

access-list 1 deny 172.16.4.13 0.0.0.0 拒绝一个主机
access-list 1 permit 0.0.0.0 255.255.255.255 允许其他
接口方向 e0 172.16.3.0 方向out
interface ethernet 0
ip access-group 1 out

access-list 1 deny 172.16.4.0 0.0.0.255 拒绝一个子网
access-list 1 permit any 允许其他
接口方向 e0 172.16.3.0 方向out
interface ethernet 0
ip access-group 1 out

扩展ACL 扩展访问列表 从100-199
access-list 101 deny ecp 172.16.4.0 0.0.0.255 172.16.3.0 0.0.0.255 eq 21 禁止172.16.4.0到172.16.3.0从E0出去的ftp服务
access-list 101 permit ip any any
interface ethernet 0
ip access-group 101 out

access-list 101 deny tcp 172.16.4.0 0.0.0.255 any eq 23 禁止网络172.16.4.0从e0出去的telnet
access-list 101 permit ip any any
interface ethernet 0
ip access-group 101 out


ACL访问控制列表vlan隔离+PAT段口多路复用
QQ截图20210317212533.png

SW

config#int f0/10
config-if#switchport mode access
config-if#switchport access vlan 10
(设置vlan10)

config#int f0/11
config-if#switchport mode access
config-if#switchport access vlan 20
(设置vlan20)

config#ip routing
(启用路由模式)

config#int vlan 10
config-if#ip address 10.0.1.1 255.255.255.0
config-if#no shutdown
(启用vlan10 SVI)

config#int vlan 20
config-if#ip address 10.0.2.1 255.255.255.0
config-if#no shutdown
(启用vlan20 SVI)

PC
IP 掩码 网关

SW(ACL vlan20隔离 其余通讯)

Switch(config)#access-list 100 deny ip 10.0.2.0 0.0.0.255 10.0.1.0 0.0.0.255 (屏蔽从1.0到2.0网段的通讯 在1.0网段上是in方向)
Switch(config)#access-list 100 deny ip 10.0.2.0 0.0.0.255 10.0.3.0 0.0.0.255
Switch(config)#access-list 100 permit ip any any (允许其他)
Switch(config)#int vlan 20 (2.0网段是vlan20)
Switch(config-if)#ip access-group 100 in (加载规则)

RT

config#int f0/0
config-if#ip address 1.1.1.1 255.255.255.0
config-if#no shutdown
(外网设置)

config#int f0/1
config-if#ip address 10.0.0.1 255.255.255.0
config-if#no shutdown
(内网设置)

SW

config#int f0/1
config-if#no switchport
config-if#ip address 10.0.0.2 255.255.255.0
(三层交换启用接口)

config#ip route 0.0.0.0 0.0.0.0 10.0.0.1
(三层交换配置静态路由)

RT

config#ip route 10.0.0.0 255.255.0.0 10.0.0.2
(路由器配置静态路由)

config#access-list 1 permit 10.0.0.0 0.0.255.255
config#ip nat in so list 1 int f0/0 overload
config#int f0/0
config-if#ip nat outside
config#int f0/1
config-if#ip nat inside
(路由器配置NAT)


Rip距离矢量内部网关协议
QQ截图20210317212636.png

rip V1

int f0/0
ip add 1.1.1.1 255.255.255.0
no sh

int f0/1
ip add 1.1.2.1 255.255.255.0
no sh

exit

router rip
network 1.1.1.0
network 1.1.2.0

rip V2

int f0/0
ip add 1.1.1.1 255.255.255.0
no sh

int f0/1
ip add 1.1.2.1 255.255.255.0
no sh

exit

router rip
version 2
no auto-summary
network 1.1.1.0
network 1.1.2.0

单臂路由+NAT复用PAT
QQ截图20210317212733.png

交换机

Switch>en
Switch#conf t
Switch(config)#interface f0/10
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#no shutdown 

Switch#conf t
Switch(config)#interface f0/11
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 20
Switch(config-if)#no shutdown 

Switch(config)#interface f0/1
Switch(config-if)#switchport mode trunk 
Switch(config-if)#no shutdown 


路由器

Router(config)#interface f0/0
Router(config-if)#no shutdown 

Router(config)#interface f0/0.10
Router(config-subif)#encapsulation dot1Q 10

Router(config)#interface f0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 172.16.20.1 255.255.255.0

Router#wr


客户端
ping

NAT复用pat
router(config)#int f0/0
router(config-if)#ip add 1.1.1.1 255.0.0.0  (设置外部端口ip)

router(config-if)#int f0/0.10    (vlan)
router(config-if)#ip add 192.168.10.1 255.255.255.0 (设置内部端口ip)

router(config)#access-list 1 permit 192.168.1.0 0.0.0.255   (定义acl或any全局)
router(config)#ip nat in so list 1 int f0/0 overload  (配置复用路由器外部端口地址转换)

router(config)#int f0/0
router(config-if)#ip nat outside
router(config-if)#int f0/1
router(config-if)#ip nat inside (在内部和外部端口启用nat)

router(config)#ip route 0.0.0.0 0.0.0.0 gateway-ip
        (配置默认路由,保证数据包正常选路路由,这里gateway通过isp下发配置)

三层交换SVI+路由器PAT
QQ截图20210317212813.png

SW

config#int f0/10
config-if#switchport mode access
config-if#switchport access vlan 10
(设置vlan10)

config#int f0/11
config-if#switchport mode access
config-if#switchport access vlan 20
(设置vlan20)

config#ip routing
(启用路由模式)

config#int vlan 10
config-if#ip address 10.0.1.1 255.255.255.0
config-if#no shutdown
(启用vlan10 SVI)

config#int vlan 20
config-if#ip address 10.0.2.1 255.255.255.0
config-if#no shutdown
(启用vlan20 SVI)

PC
IP 掩码 网关


RT

config#int f0/0
config-if#ip address 1.1.1.1 255.255.255.0
config-if#no shutdown
(外网设置)

config#int f0/1
config-if#ip address 10.0.0.1 255.255.255.0
config-if#no shutdown
(内网设置)

SW

config#int f0/1
config-if#no switchport
config-if#ip address 10.0.0.2 255.255.255.0
(三层交换启用接口)

config#ip route 0.0.0.0 0.0.0.0 10.0.0.1
(三层交换配置静态路由)

RT

config#ip route 10.0.0.0 255.255.0.0 10.0.0.2
(路由器配置静态路由)

config#access-list 1 permit 10.0.0.0 0.0.255.255
config#ip nat in so list 1 int f0/0 overload
config#int f0/0
config-if#ip nat outside
config#int f0/1
config-if#ip nat inside
(路由器配置NAT)

0

讨论

根据公安部要求,本站无评论功能,若有问题欢迎加入 QQ群419251397 讨论